Vyřešeno AuthmeReload

Status
Zamknuto

nezo

Člen
Zpráv
4
Bodů
42
Servery
ms7.hicoria.com:48460
ts3.hicoria.cz:23264
89.203.250.116
O čo ide: chcem AuthmeReload prepojit s databázou (mám vytvorenú aj mi to spravilo tabulku aj nastavilo) lenže keď server zapnem tak sa tam vidím "[AuthMe] Aborting initialization of AuthMe: [InjectorReflectionException]: Could not invoke constructor of class 'class fr.xephi.authme.command.CommandHandler'" a server sa samozrejme vypne. Verzia serveru je 1.14.4 bukkit a verzia pluginu je AuthMe 5.6.0-beta1 (sťahovaná so spigotu, najnovšia verzia).
Na serveri mám aj ProtocolLib plugin.
Prikladám authmelog

Kód:
[09-24 00:50:41]: [INFO] Connection arguments loaded, Hikari ConnectionPool ready!
[09-24 00:50:41]: [INFO] MySQL setup finished
[09-24 00:50:41]: [INFO] Hooked into PermissionsEx!
[09-24 00:50:42]: [INFO] Hooked successfully into Essentials
[09-24 00:50:42]: [WARN] Aborting initialization of AuthMe: [InjectorReflectionException]: Could not invoke constructor of class 'class fr.xephi.authme.command.CommandHandler'
[09-24 00:50:42]: fr.xephi.authme.libs.ch.jalu.injector.exceptions.InjectorReflectionException: Could not invoke constructor of class 'class fr.xephi.authme.command.CommandHandler'
    at fr.xephi.authme.libs.ch.jalu.injector.utils.ReflectionUtils.newInstance(ReflectionUtils.java:94)
    at fr.xephi.authme.libs.ch.jalu.injector.handlers.instantiation.StandardInjection.instantiateWith(StandardInjection.java:65)
    at fr.xephi.authme.libs.ch.jalu.injector.InjectorImpl.resolveContext(InjectorImpl.java:164)
    at fr.xephi.authme.libs.ch.jalu.injector.InjectorImpl.resolve(InjectorImpl.java:133)
    at fr.xephi.authme.libs.ch.jalu.injector.InjectorImpl.getSingleton(InjectorImpl.java:72)
    at fr.xephi.authme.AuthMe.instantiateServices(AuthMe.java:239)
    at fr.xephi.authme.AuthMe.initialize(AuthMe.java:212)
    at fr.xephi.authme.AuthMe.onEnable(AuthMe.java:127)
    at org.bukkit.plugin.java.JavaPlugin.setEnabled(JavaPlugin.java:263)
    at org.bukkit.plugin.java.JavaPluginLoader.enablePlugin(JavaPluginLoader.java:344)
    at org.bukkit.plugin.SimplePluginManager.enablePlugin(SimplePluginManager.java:416)
    at org.bukkit.craftbukkit.v1_14_R1.CraftServer.enablePlugin(CraftServer.java:447)
    at org.bukkit.craftbukkit.v1_14_R1.CraftServer.enablePlugins(CraftServer.java:373)
    at net.minecraft.server.v1_14_R1.MinecraftServer.a(MinecraftServer.java:440)
    at net.minecraft.server.v1_14_R1.DedicatedServer.init(DedicatedServer.java:243)
    at net.minecraft.server.v1_14_R1.MinecraftServer.run(MinecraftServer.java:754)
    at java.lang.Thread.run(Thread.java:748)
Caused by: java.lang.reflect.InvocationTargetException
    at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
    at sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:62)
    at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:45)
    at java.lang.reflect.Constructor.newInstance(Constructor.java:423)
    at fr.xephi.authme.libs.ch.jalu.injector.utils.ReflectionUtils.newInstance(ReflectionUtils.java:91)
    ... 16 more
Caused by: fr.xephi.authme.libs.ch.jalu.injector.exceptions.InjectorReflectionException: Could not invoke constructor of class 'class fr.xephi.authme.mail.EmailService'
    at fr.xephi.authme.libs.ch.jalu.injector.utils.ReflectionUtils.newInstance(ReflectionUtils.java:94)
    at fr.xephi.authme.libs.ch.jalu.injector.handlers.instantiation.StandardInjection.instantiateWith(StandardInjection.java:65)
    at fr.xephi.authme.libs.ch.jalu.injector.InjectorImpl.resolveContext(InjectorImpl.java:164)
    at fr.xephi.authme.libs.ch.jalu.injector.InjectorImpl.resolveDependencies(InjectorImpl.java:186)
    at fr.xephi.authme.libs.ch.jalu.injector.InjectorImpl.resolveContext(InjectorImpl.java:158)
    at fr.xephi.authme.libs.ch.jalu.injector.InjectorImpl.resolveDependencies(InjectorImpl.java:186)
    at fr.xephi.authme.libs.ch.jalu.injector.InjectorImpl.resolveContext(InjectorImpl.java:158)
    at fr.xephi.authme.libs.ch.jalu.injector.InjectorImpl.resolveDependencies(InjectorImpl.java:186)
    at fr.xephi.authme.libs.ch.jalu.injector.InjectorImpl.resolveContext(InjectorImpl.java:158)
    at fr.xephi.authme.libs.ch.jalu.injector.InjectorImpl.resolveDependencies(InjectorImpl.java:186)
    at fr.xephi.authme.libs.ch.jalu.injector.InjectorImpl.resolveContext(InjectorImpl.java:158)
    at fr.xephi.authme.libs.ch.jalu.injector.InjectorImpl.resolve(InjectorImpl.java:133)
    at fr.xephi.authme.libs.ch.jalu.injector.InjectorImpl.newInstance(InjectorImpl.java:77)
    at fr.xephi.authme.libs.ch.jalu.injector.handlers.dependency.FactoryDependencyHandler$FactoryImpl.newInstance(FactoryDependencyHandler.java:45)
    at fr.xephi.authme.command.CommandHandler.initializeCommands(CommandHandler.java:109)
    at fr.xephi.authme.command.CommandHandler.<init>(CommandHandler.java:49)
    ... 21 more
Caused by: java.lang.reflect.InvocationTargetException
    at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
    at sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:62)
    at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:45)
    at java.lang.reflect.Constructor.newInstance(Constructor.java:423)
    at fr.xephi.authme.libs.ch.jalu.injector.utils.ReflectionUtils.newInstance(ReflectionUtils.java:91)
    ... 36 more
Caused by: java.lang.NoSuchMethodError: org.bukkit.Server.getServerName()Ljava/lang/String;
    at fr.xephi.authme.mail.EmailService.<init>(EmailService.java:33)
    ... 41 more

[09-24 00:50:42]: [WARN] THE SERVER IS GOING TO SHUT DOWN AS DEFINED IN THE CONFIGURATION!
[09-24 00:50:42]: [INFO] AuthMe 5.6.0-beta1-b2226 disabled!
 

Dvojité V

{#21107}
Zpráv
163
Bodů
304
Místo
Hidden
Servery
zatiaľ žiadne
Dobrý večer,
Píše ti konzola túto chybu aj keď používaš file backend a nie databázu? Prípadne skús použiť tento najnovší DEV build. SŤAHUJ TU
 

nezo

Člen
Zpráv
4
Bodů
42
Servery
ms7.hicoria.com:48460
ts3.hicoria.cz:23264
89.203.250.116
Táto verzia AuthmeReload mi nefunguje. "AuthMe] You are running an unsupported server version!AuthMe requires Spigot 1.8.X or later! " Používam bukkit.
 

Dvojité V

{#21107}
Zpráv
163
Bodů
304
Místo
Hidden
Servery
zatiaľ žiadne
No takže neviem prečo používaš bukkit keď sa stále odporúča používať spigot alebo paper spigot (papermc) je to úplne to isté ako bukkit čiže pluginy ti pôjdu tak či tak avšak Spigot alebo PaperSpigot je omnoho stablijneší ako obyčajný craft-bukkit a pridáva ti omnoho viac nastavení do serveru a Paper Spigot je dokonca ešte stabilnejší a náročný ako Spigot. Takže odporúčam používať Spigot prípadne Paper Spigot.
 

nezo

Člen
Zpráv
4
Bodů
42
Servery
ms7.hicoria.com:48460
ts3.hicoria.cz:23264
89.203.250.116
Vyriešené môžete lock. Namiesto Authme používam "AdvancedLogin" (funguje aj MySQL).
 

_HeroPwP

Moderátor
Moderator
GS sekce
Zpráv
945
Bodů
1 093
Servery
mc.DarkMC.eu
Téma zamykám. Příště nezapomeňte označit téma jako vyřešeno. Návod naleznete zde.
 
Status
Zamknuto
Top